ROUTE(4) - Device Drivers Manual # ROUTE(4) - Device Drivers Manual
NAME # route - kernel packet forwarding database
SYNOPSIS # #include <sys/socket.h>
#include <net/if.h>
#include <net/route.h>
int
socket(AF_ROUTE, SOCK_RAW, family);
DESCRIPTION # OpenBSD provides some packet routing facilities. The kernel maintains a routing information database, which is used in selecting the appropriate network interface when transmitting packets.
A user process (or possibly multiple co-operating processes) maintains this database by sending messages over a special kind of socket.
...
Vmstat,
Top,
Fstat,
Pfctl,
Renice,
Sysctl,
Kill,
Netstat,
Ps,
Iostat,
Pstat,
Nfsstat,
Systat SYSTAT(1) - General Commands Manual # SYSTAT(1) - General Commands Manual
NAME # systat - display system statistics
SYNOPSIS # systat [-aBbhiNn] [-d count] [-s delay] [-w width] [view] [delay]
DESCRIPTION # systat displays various system statistics in a screen-oriented fashion using the curses(3) screen display library.
While systat is running, the screen is divided into different areas. The top line displays the current number of users, the three system load average figures over the last 1, 5, and 15 minute intervals, the host name, and the system time.
...
TCPBENCH(1) - General Commands Manual # TCPBENCH(1) - General Commands Manual
NAME # tcpbench - TCP/UDP benchmarking and measurement tool
SYNOPSIS # tcpbench -l
tcpbench [-46DRUuv] [-B buf] [-b sourceaddr] [-k kvars] [-n connections] [-p port] [-r interval] [-S space] [-T toskeyword] [-t secs] [-V rtable] hostname
tcpbench -s [-46DUuv] [-B buf] [-k kvars] [-p port] [-r interval] [-S space] [-T toskeyword] [-V rtable] [hostname]
DESCRIPTION # tcpbench is a small tool that performs throughput benchmarking and concurrent sampling of kernel network variables.
...
TCPDROP(8) - System Manager’s Manual # TCPDROP(8) - System Manager’s Manual
NAME # tcpdrop - drop a TCP connection
SYNOPSIS # tcpdrop local-addr local-port remote-addr remote-port
DESCRIPTION # The tcpdrop command drops the TCP connection specified by the local address local-addr, port local-port and the foreign address remote-addr, port remote-port. Addresses and ports can be specified by name or numeric value.
To simplify dropping TCP connections using the output of fstat(1) and netstat(1), tcpdrop also supports a two-argument form where the address and port are separated by a colon (’:’) or dot (’.
...
Vmstat,
Fstat,
Mem,
Renice,
Kill,
Stty,
Ps,
Netstat,
Systat,
Iostat,
Pstat,
Top TOP(1) - General Commands Manual # TOP(1) - General Commands Manual
NAME # top - display and update information about the top CPU processes
SYNOPSIS # top [-1bCHIinqStu] [-d count] [-g string] [-o [-]field] [-p pid] [-s time] [-T [-]rtable] [-U [-]user] [number]
DESCRIPTION # top displays the top processes on the system and periodically updates this information. If standard output is an intelligent terminal (see below) then as many processes as will fit on the terminal screen are displayed by default.
...
TRPT(8) - System Manager’s Manual # TRPT(8) - System Manager’s Manual
NAME # trpt - transliterate protocol trace
SYNOPSIS # trpt [-afjst] [-M core] [-N system] [-p hex-address]
DESCRIPTION # trpt interrogates the buffer of TCP trace records created when a socket is marked for “debugging” (see setsockopt(2)), and prints a readable description of these records. When no options are supplied, trpt prints all the trace records found in the system grouped according to TCP connection protocol control block (PCB).
...
Top,
Fstat,
Uvm_init,
Procmap,
Ps,
Netstat,
Systat,
Iostat,
Pstat,
Nfsstat,
Vmstat VMSTAT(8) - System Manager’s Manual # VMSTAT(8) - System Manager’s Manual
NAME # vmstat - report statistics about kernel activities
SYNOPSIS # vmstat [-fimstvz]
vmstat [-c count] [-M core] [-N system] [-w wait] [disk …]
DESCRIPTION # vmstat reports certain kernel statistics kept about process, virtual memory, disk, trap, and CPU activity. The default behavior is to print a one-line summary of these statistics. The -c and -w flags may be used to continually report summaries.
...