implementation of the iCalendar protocols and data units
Project homepage: https://libical.github.io/libical/
Description
Libical is an Open Source implementation of the iCalendar protocols and
protocol data units. The iCalendar specification describes how calendar
clients can communicate with calendar servers so users can store their
calendar data and arrange meetings with other users.
Libical implements RFC2445, RFC2446 and some of RFC2447.
Package information
- Ports path
- textproc/libical
- Package architecture
- amd64
- Maintainer
- Antoine Jacoutot <ajacoutot@openbsd.org>
- Categories
- textproc, lang/python
- Available flavors
- None listed
- Only for architectures
- aarch64, amd64, arm, i386, mips64, mips64el, powerpc, powerpc64, riscv64, sparc64, alpha, hppa, m88k, sh
Ports list build and test dependencies as well as runtime dependencies. pkg_add selects those needed for installation.
Direct dependencies
Library
Build
- devel/gobject-introspection
- lang/vala
- textproc/libxml
- devel/cmake/core STEM->=4
- devel/ninja
- lang/python/3
- devel/dwz
Test
- lang/python/3
- textproc/libical,-glib STEM-=4.0.5
Used by (13 dependency relationships)
Includes library, runtime, build and test dependencies.