{"schema_version":1,"metadata":{"branch":"release","release":"8.0","architecture":"amd64","generated_at":"2026-10-21T02:35:53.703506+00:00","source_url":"https://cdn.openbsd.org/pub/OpenBSD/8.0/packages/amd64/sqlports-7.55.tgz","source_sha256":"393d2bd6f5b23c8ba1809ec63f3e8310d7787d329b7350089609a078eb01a387","package_count":12098,"source_kind":"sqlports"},"package":{"name":"py3-precis_i18n-1.1.2p0","path":"textproc/py-precis_i18n","url":"/packages/release/textproc/py-precis_i18n/","comment":"internationalized usernames and passwords","homepage":"https://pypi.org/project/precis_i18n","maintainer":"The OpenBSD ports mailing-list <ports@openbsd.org>","description":"The PRECIS framework makes internationalized user names and passwords safer for\nuse by applications. PRECIS profiles transform unicode strings into a canonical\nform, suitable for comparison.\n\nThis Python module implements the PRECIS framework as described in:\n\n- PRECIS Framework: Preparation, Enforcement, and Comparison of\n  Internationalized Strings in Application Protocols (RFC 8264)\n\n- Preparation, Enforcement, and Comparison of Internationalized Strings\n  Representing Usernames and Passwords (RFC 8265)\n\n- Preparation, Enforcement, and Comparison of Internationalized Strings\n  Representing Nicknames (RFC 8266)\n","description_source":null,"description_unresolved":[],"package_architecture":"amd64","stem":"py3-precis_i18n","readme":null,"dependencies":[{"path":"lang/python/3","type":"runtime","package_spec":"","url":"/packages/release/lang/python/3/"},{"path":"lang/python/3","type":"build","package_spec":"","url":"/packages/release/lang/python/3/"},{"path":"devel/py-build","type":"build","package_spec":"","url":"/packages/release/devel/py-build/"},{"path":"devel/py-installer","type":"build","package_spec":"","url":"/packages/release/devel/py-installer/"},{"path":"devel/py-setuptools","type":"build","package_spec":"py3-setuptools->=79v0","url":"/packages/release/devel/py-setuptools/"},{"path":"devel/py-wheel","type":"build","package_spec":"","url":"/packages/release/devel/py-wheel/"},{"path":"lang/python/3","type":"test","package_spec":"","url":"/packages/release/lang/python/3/"},{"path":"devel/py-test","type":"test","package_spec":"","url":"/packages/release/devel/py-test/"}],"reverse_dependencies":{"count":4,"url":"/packages/data/48/48aa59a1a7bb4ac2848d1d8cf85bef727037cc4281ca1d3589dbe29e9f30ecca.json"},"categories":["textproc","security","lang/python"],"flavors":[],"only_for_architectures":["aarch64","amd64","arm","i386","mips64","mips64el","powerpc","powerpc64","riscv64","sparc64","alpha","hppa"],"not_for_architectures":[]}}
