{"schema_version":1,"metadata":{"branch":"release","release":"8.0","architecture":"amd64","generated_at":"2026-10-21T02:35:53.703506+00:00","source_url":"https://cdn.openbsd.org/pub/OpenBSD/8.0/packages/amd64/sqlports-7.55.tgz","source_sha256":"393d2bd6f5b23c8ba1809ec63f3e8310d7787d329b7350089609a078eb01a387","package_count":12098,"source_kind":"sqlports"},"package":{"name":"lego-4.35.2","path":"security/lego","url":"/packages/release/security/lego/","comment":"Let's Encrypt/ACME client written in Go","homepage":"https://go-acme.github.io/lego/","maintainer":"Horia Racoviceanu <horia@racoviceanu.com>","description":"Lego can be use as a Let's Encrypt/ACME CLI and can solve multiple ACME\nchallenge types out of the box or use custom challenge solvers.\n\nFeatures:\n- ACME v2 RFC 8555\n  - Support RFC 8737: TLS Application-Layer Protocol Negotiation (ALPN)\n    Challenge Extension\n  - Support RFC 8738: certificates for IP addresses\n  - Support RFC 9773: Renewal Information (ARI) Extension\n  - Support draft-ietf-acme-profiles-00: Profiles Extension\n- Register with CA\n- Obtain certificates, both from scratch or with an existing CSR\n- Renew certificates\n- Revoke certificates\n- Robust implementation of all ACME challenges\n  - HTTP (http-01)\n  - DNS (dns-01)\n  - TLS (tls-alpn-01)\n- SAN certificate support\n- CNAME support by default\n- Comes with multiple optional DNS providers\n- Custom challenge solvers\n- Certificate bundling\n- OCSP helper function\n","description_source":null,"description_unresolved":[],"package_architecture":"amd64","stem":"lego","readme":null,"dependencies":[{"path":"lang/go","type":"build","package_spec":"","url":"/packages/release/lang/go/"},{"path":"archivers/unzip","type":"build","package_spec":"","url":"/packages/release/archivers/unzip/"}],"reverse_dependencies":{"count":0,"url":null},"categories":["security","lang/go"],"flavors":[],"only_for_architectures":["aarch64","amd64","arm","i386","riscv64"],"not_for_architectures":[]}}
