internationalized usernames and passwords
Project homepage: https://pypi.org/project/precis_i18n
Description
The PRECIS framework makes internationalized user names and passwords safer for
use by applications. PRECIS profiles transform unicode strings into a canonical
form, suitable for comparison.
This Python module implements the PRECIS framework as described in:
- PRECIS Framework: Preparation, Enforcement, and Comparison of
Internationalized Strings in Application Protocols (RFC 8264)
- Preparation, Enforcement, and Comparison of Internationalized Strings
Representing Usernames and Passwords (RFC 8265)
- Preparation, Enforcement, and Comparison of Internationalized Strings
Representing Nicknames (RFC 8266)
Package information
- Ports path
- textproc/py-precis_i18n
- Package architecture
- amd64
- Maintainer
- The OpenBSD ports mailing-list <ports@openbsd.org>
- Categories
- textproc, security, lang/python
- Available flavors
- None listed
- Only for architectures
- aarch64, amd64, arm, i386, mips64, mips64el, powerpc, powerpc64, riscv64, sparc64, alpha, hppa
Ports list build and test dependencies as well as runtime dependencies. pkg_add selects those needed for installation.
Direct dependencies
Runtime
Build
- lang/python/3
- devel/py-build
- devel/py-installer
- devel/py-setuptools py3-setuptools->=79v0
- devel/py-wheel
Test
Used by (4 dependency relationships)
Includes library, runtime, build and test dependencies.