1135 packages · A–Z
Ports catalogue: amd64.
- py3-confuse-2.2.0
painless YAML configuration
textproc/py-confuse - py3-cparser-3.0
C parser in pure Python
devel/py-cparser - py3-cson-0.8p4
parser for Coffeescript Object Notation (CSON)
textproc/py-cson - py3-css-parser-1.0.10p3
python package for parsing and building CSS
textproc/py-css-parser - py3-cssselect-1.4.0p0
parse CSS3 Selectors and translates them to XPath 1.0
textproc/py-cssselect - py3-cssselect2-0.9.0p0
implementation of CSS4 Selectors
textproc/py-cssselect2 - py3-cssutils-2.11.1p0
parse and build CSS from Python
textproc/py-cssutils - py3-dateparser-1.4.0
parse dates from HTML pages
textproc/py-dateparser - py3-defusedxml-0.7.1p7
XML bomb protection for Python stdlib modules
textproc/py-defusedxml - py3-demjson-3.0.6p3
encoder, decoder, and lint/validator for JSON
textproc/py-demjson - py3-dict2xml-1.7.8
convert a Python dictionary into an XML file
textproc/py-dict2xml - py3-dicttoxml-1.7.16p4
convert dicts and other data types into XML
textproc/py-dicttoxml - py3-diff-match-patch-20241021p1
high-performance diff and patch library
textproc/py-diff-match-patch - py3-docutils-0.22.4v0
process plaintext documentation into other formats
textproc/py-docutils - py3-docx-1.2.0
library for processing .docx files
textproc/py-docx - py3-elasticsearch-7.17.0p4
Python client for Elasticsearch
textproc/py-elasticsearch - py3-elementpath-4.8.0p0
xpath 1.0/2.0 parsers and selectors for elementtree
textproc/py-elementpath - py3-emoji-2.14.1p0
emoji for Python
textproc/py-emoji - py3-enchant-3.3.0p0
spellchecking library for Python
textproc/py-enchant - py3-et_xmlfile-2.0.0p0
low memory library for creating large XML files
textproc/py-et_xmlfile - py3-fastjsonschema-2.21.2
fast Python implementation of JSON schema
textproc/py-fastjsonschema - py3-feedgenerator-1.9.1p8
standalone version of Django's feedgenerator
www/py-feedgenerator - py3-feedparser-6.0.12
RSS and Atom feeds parser written in Python
textproc/py-feedparser - py3-fpdf2-2.8.7
PDF creation library for Python
textproc/py-fpdf2 - py3-gTTS-2.5.4p2
Google Translate text-to-speech API library and CLI tool
textproc/py-gTTS - py3-html5lib-1.1p6
HTML parser/tokeniser based for HTML5
devel/py-html5lib - py3-humanfriendly-10.0p3
human-friendly output for Python text interfaces
textproc/py-humanfriendly - py3-humanize-4.3.0p3
python number humanization utilities
textproc/py-humanize - py3-icecream-2.2.0
print() replacement that can handle data structures
textproc/py-icecream - py3-ICU-2.16.2
Python extension wrapping the ICU C++ API
textproc/py-ICU - py3-ijson-3.4.0pl0
iterative JSON parser
textproc/py-ijson - py3-inflect-7.5.0p0
correctly generate plurals, singular nouns, ordinals, etc
textproc/py-inflect - py3-inflection-0.5.1p3
singularizes and pluralizes English words
textproc/py-inflection - py3-ini2toml-0.15p1
convert .ini/.cfg files to TOML equivalents
textproc/py-ini2toml - py3-iniconfig-2.3.0
brain-dead simple config-ini parsing
textproc/py-iniconfig - py3-ipython_pygments_lexers-1.1.1
pygments plugin for ipython
textproc/py-ipython_pygments_lexers - py3-iso8601-2.1.0p2
Python module to parse ISO 8601 dates
textproc/py-iso8601 - py3-jaraco.text-4.2.0
handy routines for dealing with text
textproc/py-jaraco-text - py3-jellyfish-1.2.1
Python library for approximate and phonetic string matching
textproc/py-jellyfish - py3-json5-0.12.1p0
Python implementation of json5
textproc/py-json5 - py3-jsonpatch-1.33p2
library to apply JSON Patches according to RFC 6902
textproc/py-jsonpatch - py3-jsonpointer-2.4p2
library to resolve JSON Pointers according to RFC 6901
textproc/py-jsonpointer - py3-jupyterlab_pygments-0.3.0p0
pygments theme using jupyterlab CSS variables
textproc/py-jupyterlab_pygments - py3-langdetect-1.0.9p1
python language-detection library
textproc/py-langdetect - py3-lark-1.3.1
parsing toolkit for Python
textproc/py-lark - py3-laspy-2.7.0p0
library for reading, modifying and creating LAS LiDAR files
geo/py-laspy - py3-libmarisa-0.2.6p8
marisa-trie bindings for Python (SWIG)
textproc/libmarisa,-python - py3-license-expression-30.4.4p0
parse, normalize and compare License expressions
textproc/py-license-expression - py3-link-grammar-5.13.0p0
Python bindings for link-grammar
textproc/link-grammar,-python - py3-lxml-6.0.2
Python binding for the libxml2 and libxslt libraries
textproc/py-lxml - py3-lxml-html-clean-0.4.4
HTML cleaner from the lxml project
textproc/py-lxml-html-clean - py3-markdown-3.10.2p0
text-to-HTML conversion tool
textproc/py-markdown - py3-markdown-it-4.0.0p0
markdown parsing for Python, port of markdown-it
textproc/py-markdown-it - py3-markups-4.1.1
wrapper around various text markup languages
textproc/py-markups - py3-MarkupSafe-3.0.3p0
implements an XML/HTML/XHTML markup safe string
textproc/py-MarkupSafe - py3-mdown-extensions-10.21.2
extensions for python-markdown
textproc/py-mdown-extensions - py3-mdurl-0.1.2p3
URL utilities for markdown-it parser
textproc/py-mdurl - py3-meld3-2.0.1p5
html/xml templating engine
www/py-meld3 - py3-mistune-3.2.0
markdown parser for Python
textproc/py-mistune - py3-msgpack-1.1.2v0
messagepack (de)serializer
net/py-msgpack - py3-natsort-8.4.0p2
simple yet flexible natural sorting
textproc/py-natsort - py3-nltk-3.9.4v0
Natural Language ToolKit
textproc/py-nltk - py3-numpydoc-1.10.0
Sphinx extension to support docstrings in Numpy format
textproc/py-numpydoc - py3-odfpy-1.4.1p6
Python API and tools to manipulate OpenDocument files
textproc/py-odfpy - py3-ofxparse-0.21p8
parser for the Open Financial Exchange file format
textproc/py-ofxparse - py3-openpyxl-3.1.5p1
Python library to read/write Excel 2010 xlsx/xlsm files
textproc/py-openpyxl - py3-orjson-3.11.4
fast, correct Python JSON library
textproc/py-orjson - py3-pandocfilters-1.4.2p1
utilities for writing pandoc filters
textproc/py-pandocfilters - py3-patiencediff-0.2.18
Python implementation of the patiencediff algorithm
textproc/py-patiencediff - py3-pdfminer-20260107
PDF parser and analyzer
textproc/py-pdfminer - py3-PEG2-2.15.2p10
PEG Parser-Interpreter in Python
textproc/py-PEG2 - py3-podcastparser-0.6.10p4
simple, fast and efficient podcast parser
textproc/py-podcastparser - py3-polib-1.2.0p1
Python library to manipulate gettext files
textproc/py-polib - py3-precis_i18n-1.1.2p0
internationalized usernames and passwords
textproc/py-precis_i18n - py3-prettytable-0.7.2p11
Python library for pretty-printing tabular data
textproc/py-prettytable - py3-pyaml-25.7.0
module/tool to produce pretty and readable YAML
textproc/py-pyaml - py3-pygfm-2.0.0
deprecated GitHub Flavored Markdown extension
textproc/py-pygfm - py3-pygments-2.20.0
Python syntax highlighter
textproc/py-pygments - py3-pyjson5-2.0.0
json5 serializer and parser written in Cython
textproc/py-pyjson5 - py3-pykwalify-1.8.0p5
lib/cli for JSON/YAML schema validation
textproc/py-pykwalify - py3-pypandoc-1.16.2
Python wrapper for pandoc
textproc/py-pypandoc - py3-PyPDF2-2.12.1p1
PDF Python toolkit
textproc/py-PyPDF2 - py3-pyphen-0.17.2p1
pure-Python hyphenation library
textproc/py-pyphen - py3-pyRFC3339-1.1p6
format dates according to RFC3339
textproc/py-pyRFC3339 - py3-python-json-logger-2.0.7p2
Python library adding a json log formatter
textproc/py-python-json-logger - py3-python-markdown-math-0.9
math extension for Python-Markdown
textproc/py-python-markdown-math - py3-pyuca-1.2p0
unicode collation algorithm
textproc/py-pyuca - py3-qrcode-8.2p1
QR Code image generator
graphics/py-qrcode - py3-rebulk-3.2.0p2
define simple search patterns in bulk to perform
textproc/py-rebulk - py3-recommonmark-0.7.1p7
markdown parser for docutils
textproc/py-recommonmark - py3-referencing-0.37.0p0
JSON referencing in Python
textproc/py-referencing - py3-regress-2025.10.1
bindings for ECMA regular expressions in the regress crate
textproc/py-regress - py3-relatorio-0.11.1p3
templating library able to output odt and pdf files
print/py-relatorio - py3-rjsmin-1.2.5
javascript minifier written in python
textproc/py-rjsmin - py3-roman-numerals-4.1.0p0
manipulate well-formed Roman nunerals
textproc/py-roman-numerals - py3-rst2ansi-0.1.5p4
convert rst to ANSI-decorated console output
textproc/py-rst2ansi - py3-ruamel.yaml-0.19.1
YAML 1.2 loader/dumper package for Python
textproc/py-ruamel.yaml - py3-ruamel.yaml.clib-0.2.15
C based reader/scanner and emitter for ruamel.yaml
textproc/py-ruamel.yaml.clib - py3-semver-3.0.4p1
Python helper for Semantic Versioning
textproc/py-semver - py3-signedjson-1.1.4p3
sign JSON with Ed25519 signatures
textproc/py-signedjson