OpenBSD Handbook

    Theme
    • Part I. Install & Configure
      • Introduction to OpenBSD
      • Installing OpenBSD
      • The X Window System
      • Networking on OpenBSD
      • System Configuration
      • OpenBSD Basics
      • Managing Software: Packages and Ports
    • Part II. Daily Operations
      • OpenBSD Desktop Environments
      • Multimedia
      • Printing
      • Linux Compatibility
      • Windows Compatibility
      • Games
    • Part III. System Administration
      • Virtualization
      • Storage and File Systems
      • Updating and Upgrading
      • Localization
      • The OpenBSD Boot Process
      • Security
    • Part IV. Networking & Daemons
      • Services
        • Database
          • MariaDB
          • PostgreSQL
          • Redis
          • memcached
        • Directory
          • YP (NIS)
          • LDAP
        • File
          • NFS
          • Samba
        • FTP Services
          • ftpd
          • ProFTPD
          • vsftpd
          • Pure-FTPd
          • TFTP
        • Mail
          • OpenSMTPD Mail Server
          • Dovecot IMAP and POP3 Server
          • Postfix
          • Exim
          • Rspamd
        • Name
          • Unbound DNS Resolver
          • NSD Authoritative DNS Server
          • BIND DNS Server
        • Networking
          • OpenBGPD
          • rad
          • DHCP on OpenBSD
          • slaacd
        • Web
          • Apache HTTP Server
          • nginx Web Server
          • OpenBSD httpd Web Server
          • relayd Reverse Proxy
        • Logging
          • syslogd
        • Monitoring
          • SNMP
        • Remote Access
          • Audit OpenSSH
          • OpenSSH Server
        • File Synchronization
          • rsync
        • Messaging
          • RabbitMQ Message Broker
        • Time
          • NTP Time Synchronization
      • PF
        • pfctl cheat sheet
        • PF Anchors
        • PF Filter Rules
        • PF Forwarding
        • PF Lists and Macros
        • PF Load Balancing
        • PF Logging
        • PF NAT
        • PF Options
        • PF Policies
        • PF Shortcuts
        • PF Tables
      • Advanced Networking
        • High Availability and State Replication
        • Multi-WAN and Policy-Based Routing
        • VPN and Cryptographic Tunneling
        • Classic and Lightweight Tunnels
        • IPv6 at Scale
        • QoS and Traffic Shaping
        • MPLS and Label Distribution
        • Network Services at Scale
        • Virtualization and Host Networking
        • Large-Scale L2 and L3 Design
        • Telemetry, Logging, and Flow Export
        • Hardening and Operational Safety
        • Reference Architectures
        • Troubleshooting Playbooks
      • Serial Communication
    • Part V. Miscellaneous
      • Virtualization Cheat Sheet
      • OpenBSD Cheatsheet
      • How-to Guides
        • Complete the First 30 Minutes After Installation
        • Check Hardware Compatibility Before Installing
        • Bootstrap Wi-Fi Firmware Without Ethernet
        • Set Up OpenBSD as a Laptop or Workstation
        • Configure Laptop Power Management
        • Run OpenBSD as a Virtual Machine Guest
        • Install OpenBSD on a VPS or Cloud Server
        • Install OpenBSD with Full-Disk Encryption
        • Troubleshoot Web Browsers on OpenBSD
        • Create an Administrator Account with doas and SSH Keys
        • Establish a Conservative Security Baseline
        • Manage OpenBSD with Ansible
        • Recover Access and Reset the Root Password
        • Collect OpenBSD Diagnostic Evidence
        • Configure Secure Remote Access with OpenSSH
        • Set Up WordPress on OpenBSD
        • Build Third-Party Software from Ports
        • Use FIDO Security Keys with OpenSSH
        • Build OpenBSD from Source
        • Configure Wi-Fi Roaming and Wired Failover
        • Dual-Boot OpenBSD on a UEFI System
        • Troubleshoot PF, NAT, and Routing
        • Automate OpenBSD Installation with Autoinstall and PXE
        • Route Multiple VLANs with PF
        • Configure a Road-Warrior WireGuard VPN
        • Troubleshoot Package Installation and Update Failures
        • Route IPv6 Networks without NAT
        • Schedule Recurring Maintenance
        • Plan a Docker Workload Migration to OpenBSD
        • Build a Mail Server with OpenSMTPD, Dovecot, and Rspamd
        • Build a Simple Router and Firewall
        • Monitor an OpenBSD System
        • Back Up and Restore an OpenBSD System
        • Configure softraid RAID1
        • Recover an OpenBSD System That Does Not Boot
        • Install Z shell (zsh)
      • OpenBSD for Linux Users
      • OpenBSD for FreeBSD Users
      • OpenBSD for macOS Users
    • OpenBSD FAQ
    • OpenBSD Architectures
      • OpenBSD Package Search

        perl5 packages — Page 7

        OpenBSD 7.9 release Current snapshot

        All categories

        1964 packages · A–Z

        Ports catalogue: amd64.

        Jump to:0–9ABCDEFGHIJKLMNOPQRSTUVWXYZ
        Previous · Page 7 of 20 · Next
        • p5-Digest-SHA3-1.05

          Perl extension for SHA-3

          security/p5-Digest-SHA3
        • p5-Digest-Skein-0.05p4

          interface to the Skein digest algorithm

          security/p5-Digest-Skein
        • p5-Digest-ssdeep-0.9.3

          Pure Perl ssdeep (CTPH) fuzzy hashing

          security/p5-Digest-ssdeep
        • p5-Dir-Self-0.11p0

          __DIR__ constant for the directory your source file is in

          devel/p5-Dir-Self
        • p5-Directory-Scratch-0.18p0

          easy-to-use self-cleaning scratch space

          devel/p5-Directory-Scratch
        • p5-Dist-CheckConflicts-0.11p0

          declare version conflicts for your dist

          devel/p5-Dist-CheckConflicts
        • p5-DNS-ZoneParse-1.10p1

          parse and manipulate DNS Zone files

          net/p5-DNS-ZoneParse
        • p5-Drupal-Admin-0.04p3

          screen scraping Perl API to some Drupal admin functions

          www/p5-Drupal-Admin
        • p5-Dumbbench-0.505

          more reliable benchmarking

          benchmarks/p5-Dumbbench
        • p5-Email-Abstract-3.010

          unified interface to mail representations

          mail/p5-Email-Abstract
        • p5-Email-Address-1.913

          RFC 2822 address parsing and creation

          mail/p5-Email-Address
        • p5-Email-Address-List-0.06p0

          RFC close address list parsing

          mail/p5-Email-Address-List
        • p5-Email-Address-XS-1.05

          parse and format RFC 5322 email addresses and groups

          mail/p5-Email-Address-XS
        • p5-Email-Date-1.104p0

          find and format date headers

          mail/p5-Email-Date
        • p5-Email-Date-Format-1.008

          produce RFC 2822 date strings

          mail/p5-Email-Date-Format
        • p5-Email-Filter-1.034p0

          library for creating easy email filters

          mail/p5-Email-Filter
        • p5-Email-Filter-Rules-1.2p0

          simple rules for routing mail with Email::Filter

          mail/p5-Email-Filter-Rules
        • p5-Email-Find-0.10p1

          Find RFC 822 email addresses in plain text

          textproc/p5-Email-Find
        • p5-Email-Folder-0.860p1

          read an email folder as Email::Simple objects

          mail/p5-Email-Folder
        • p5-Email-FolderType-0.814p1

          determine email folder type

          mail/p5-Email-FolderType
        • p5-Email-LocalDelivery-1.201

          deliver a piece of mail locally

          mail/p5-Email-LocalDelivery
        • p5-Email-MessageID-1.408

          generate world unique message-ids

          mail/p5-Email-MessageID
        • p5-Email-MIME-1.954v0

          easy MIME message handling

          mail/p5-Email-MIME
        • p5-Email-MIME-Attachment-Stripper-1.317p0

          strip the attachments from an e-mail

          mail/p5-Email-MIME-Attachment-Stripper
        • p5-Email-MIME-ContentType-1.028

          parse MIME Content-Type or Content-Disposition headers

          mail/p5-Email-MIME-ContentType
        • p5-Email-MIME-Encodings-1.317

          unified interface to MIME encoding and decoding

          mail/p5-Email-MIME-Encodings
        • p5-Email-Received-1.00p1

          parse an email Received: header

          mail/p5-Email-Received
        • p5-Email-Reply-1.204p0

          module to generate replies to e-mail messages.

          mail/p5-Email-Reply
        • p5-Email-Send-2.202

          simply sending email

          mail/p5-Email-Send
        • p5-Email-Sender-2.601

          library for sending email

          mail/p5-Email-Sender
        • p5-Email-Simple-2.218

          simple parsing of RFC2822 message format and headers

          mail/p5-Email-Simple
        • p5-Email-Valid-1.204

          check validity of Internet email addresses

          mail/p5-Email-Valid
        • p5-Email-Valid-Loose-0.05p1

          allows non RFC822 addresses common in japan

          mail/p5-Email-Valid-Loose
        • p5-Encode-Detect-1.01p8

          Encode::Encoding subclass that detects the encoding of data

          textproc/p5-Encode-Detect
        • p5-Encode-HanExtra-0.23p0

          extra sets of Chinese encodings

          textproc/p5-Encode-HanExtra
        • p5-Encode-IMAPUTF7-1.07

          modification of UTF-7 encoding for IMAP

          converters/p5-Encode-IMAPUTF7
        • p5-Encode-Locale-1.05p0

          determine the locale encoding

          textproc/p5-Encode-Locale
        • p5-enum-1.12v0

          C style enumerated types and bitmask flags

          devel/p5-enum
        • p5-Env-PS1-0.06p1

          env prompter for zoid shell

          devel/p5-Env-PS1
        • p5-Error-0.17030

          error/exception handling in an OO-ish way

          devel/p5-Error
        • p5-EV-4.37

          perl interface to libev

          devel/p5-EV
        • p5-Eval-Closure-0.14p0

          safely and cleanly create closures via string eval

          devel/p5-Eval-Closure
        • p5-Event-1.28

          event loop processing

          devel/p5-Event
        • p5-Event-ExecFlow-0.64p0

          high level API for event-based execution flow control

          devel/p5-Event-ExecFlow
        • p5-Event-RPC-1.11

          Event based transparent Client/Server RPC framework

          net/p5-Event-RPC
        • p5-Exception-Class-1.45

          module to declare real exception classes in perl

          devel/p5-Exception-Class
        • p5-Exception-Class-TryCatch-1.13p0

          syntactic try/catch sugar for use with Exception::Class

          devel/p5-Exception-Class-TryCatch
        • p5-Expect-1.38

          talk to other applications

          devel/p5-Expect
        • p5-Expect-Simple-0.04p1

          wrapper around the Expect module

          devel/p5-Expect-Simple
        • p5-Exporter-Lite-0.09

          lightweight exporting of functions and variables

          devel/p5-Exporter-Lite
        • p5-Exporter-Tidy-0.06p2

          alternative to the standard perl exporter

          devel/p5-Exporter-Tidy
        • p5-Exporter-Tiny-1.006003

          exporter with the features of Sub::Exporter

          devel/p5-Exporter-Tiny
        • p5-ExtUtils-CChecker-0.12p0

          configure-time utilities for using C headers, etc.

          devel/p5-ExtUtils-CChecker
        • p5-ExtUtils-Config-0.010

          wrapper for perl's configuration

          devel/p5-ExtUtils-Config
        • p5-ExtUtils-CppGuess-0.27

          guess C++ compiler and flags

          devel/p5-ExtUtils-CppGuess
        • p5-ExtUtils-Depends-0.306p0

          easily build XS extensions that depend on XS extensions

          devel/p5-ExtUtils-Depends
        • p5-ExtUtils-Helpers-0.028

          various portability utilities for module builders

          devel/p5-ExtUtils-Helpers
        • p5-ExtUtils-InstallPaths-0.015

          Build.PL install path logic made easy

          devel/p5-ExtUtils-InstallPaths
        • p5-ExtUtils-PkgConfig-1.16p0

          simplistic perl interface to pkg-config

          devel/p5-ExtUtils-PkgConfig
        • p5-ExtUtils-Typemaps-Default-1.05p1

          set of useful typemaps

          devel/p5-ExtUtils-Typemaps-Default
        • p5-ExtUtils-XSBuilder-0.28p3

          automatic Perl XS glue code generation

          devel/p5-ExtUtils-XSBuilder
        • p5-ExtUtils-XSpp-0.18p0

          XS for C++

          devel/p5-ExtUtils-XSpp
        • p5-FCGI-0.82p0

          module for enabling FastCGI support in CGI scripts

          www/p5-FCGI
        • p5-FCGI-ProcManager-0.28p0

          functions for managing FastCGI applications

          www/p5-FCGI-ProcManager
        • p5-Feature-Compat-Try-0.05

          make try/catch syntax available

          devel/p5-Feature-Compat-Try
        • p5-Feed-Find-0.13

          autodiscover syndication feeds

          www/p5-Feed-Find
        • p5-FFI-CheckLib-0.31p0

          check that a library is available for FFI

          devel/p5-FFI-CheckLib
        • p5-File-Attributes-0.04p6

          manipulate file metadata

          devel/p5-File-Attributes
        • p5-File-Attributes-Recursive-0.02p2

          inherit file attributes from parent directories

          devel/p5-File-Attributes-Recursive
        • p5-File-BaseDir-0.09

          use the freedesktop Base Directory Specification

          devel/p5-File-BaseDir
        • p5-File-BOM-0.18

          utilities for handling Byte Order Marks

          devel/p5-File-BOM
        • p5-File-ChangeNotify-0.31p1

          watch for changes to files, cross-platform style

          devel/p5-File-ChangeNotify
        • p5-File-chdir-0.1011

          more sensible way to change directories

          devel/p5-File-chdir
        • p5-File-chmod-0.42p0

          implements symbolic and ls chmod modes

          devel/p5-File-chmod
        • p5-File-Copy-Recursive-0.45p0

          recursive copy of files and directories

          devel/p5-File-Copy-Recursive
        • p5-File-CreationTime-2.04p2

          keeps track of file creation times

          devel/p5-File-CreationTime
        • p5-File-DesktopEntry-0.23

          handle .desktop files

          devel/p5-File-DesktopEntry
        • p5-File-DirCompare-0.7p2

          compare two directories using callbacks

          devel/p5-File-DirCompare
        • p5-File-FcntlLock-0.22

          file locking with fcntl(2)

          devel/p5-File-FcntlLock
        • p5-File-Find-Object-0.3.9

          object oriented File::Find replacement

          devel/p5-File-Find-Object
        • p5-File-Find-Object-Rule-0.0313

          alternative interface to File::Find::Object

          devel/p5-File-Find-Object-Rule
        • p5-File-Find-Rule-0.35

          alternative interface to File::Find

          devel/p5-File-Find-Rule
        • p5-File-Find-Rule-Filesys-Virtual-1.22p1

          File::Find::Rule adapted to Filesys::Virtual

          devel/p5-File-Find-Rule-Filesys-Virtual
        • p5-File-Find-Rule-Perl-1.16

          common rules for searching for Perl things

          devel/p5-File-Find-Rule-Perl
        • p5-File-Finder-1.01

          wrapper around File::Find

          devel/p5-File-Finder
        • p5-File-Flat-1.07

          implements a flat filesystem

          devel/p5-File-Flat
        • p5-File-FnMatch-0.02p2

          simple filename and pathname matching

          devel/p5-File-FnMatch
        • p5-File-HomeDir-1.006

          retrieve home directory location

          devel/p5-File-HomeDir
        • p5-File-KDBX-0.906p0

          interface to KeePass KDB and KDBX database files

          textproc/p5-File-KDBX
        • p5-File-KeePass-2.03p2

          interface to KeePass V1 and V2 database files

          textproc/p5-File-KeePass
        • p5-File-LibMagic-1.23

          perl wrapper for libmagic

          misc/p5-File-LibMagic
        • p5-File-Listing-6.16

          parse directory listing

          devel/p5-File-Listing
        • p5-File-LoadLines-0.02

          load the contents of a text file into an array of lines

          devel/p5-File-LoadLines
        • p5-File-MimeInfo-0.36

          determine file types

          devel/p5-File-MimeInfo
        • p5-File-MMagic-1.30p0

          perl module to guess file type from contents

          misc/p5-File-MMagic
        • p5-File-MMagic-XS-0.09008p3

          guess file type with XS (a la mod_mime_magic)

          misc/p5-File-MMagic-XS
        • p5-File-Modified-0.10p0

          checks intelligently if files have changed

          devel/p5-File-Modified
        • p5-File-Monitor-1.00p0

          monitor files and directories for changes

          sysutils/p5-File-Monitor
        • p5-File-NCopy-0.36

          copy files and directories with perl

          devel/p5-File-NCopy
        • p5-File-Next-1.18p0

          File-finding iterator

          devel/p5-File-Next
        Previous · Page 7 of 20 · Next
        Report a bug