DIR(5) - File Formats Manual #
DIR(5) - File Formats Manual
NAME #
dir, dirent - directory file format
SYNOPSIS #
#include <dirent.h>
DESCRIPTION #
Directories provide a convenient hierarchical method of grouping files while obscuring the underlying details of the storage medium. A directory file is differentiated from a plain file by a flag in its inode(5) entry. It consists of records (directory entries) each of which contains information about a file and a pointer to the file itself. Directory entries may contain other directories as well as plain files; such nested directories are referred to as subdirectories. A hierarchy of directories and files is formed in this manner and is called a file system (or referred to as a file system tree).
Each directory file contains two special directory entries; one is a pointer to the directory itself called dot (".") and the other a pointer to its parent directory called dot-dot (".."). Dot and dot-dot are valid pathnames, however, the system root directory ("/"), has no parent and dot-dot points to itself like dot.
File system nodes are ordinary directory files on which has been grafted a file system object, such as a physical disk or a partitioned area of such a disk (see mount(8)).
The directory entry format is defined in the file <dirent.h>:
/*
* A directory entry has a struct dirent at the front of it, containing
* its inode number, the length of the entry, and the length of the name
* contained in the entry. These are followed by the name padded to some
* alignment (currently 8 bytes) with NUL bytes. All names are guaranteed
* NUL terminated. The maximum length of a name in a directory is MAXNAMLEN.
*/
struct dirent {
ino_t d_fileno; /* file number of entry */
off_t d_off; /* offset of next entry */
u_int16_t d_reclen; /* length of this record */
u_int8_t d_type; /* file type, see below */
u_int8_t d_namlen; /* length of string in d_name */
#define MAXNAMLEN 255
char d_name[MAXNAMLEN + 1]; /* maximum name length */
};
#define d_ino d_fileno /* backward compatibility */
/*
* File types
*/
#define DT_UNKNOWN 0
#define DT_FIFO 1
#define DT_CHR 2
#define DT_DIR 4
#define DT_BLK 6
#define DT_REG 8
#define DT_LNK 10
#define DT_SOCK 12
SEE ALSO #
HISTORY #
A dir file format appeared in VersionĀ 1 AT&T UNIX. A predecessor struct direct first appeared in VersionĀ 7 AT&T UNIX. The dirent structure first appeared in 4.3BSD-Reno. The d_off member was added in OpenBSD 5.5.
OpenBSD 7.5 - September 7, 2019