UHID(4) - Device Drivers Manual #
UHID(4) - Device Drivers Manual
NAME #
uhid - USB generic HID support
SYNOPSIS #
uhid* at uhidev?
#include <dev/usb/usb.h>
DESCRIPTION #
The uhid driver provides support for all HID (Human Interface Device) interfaces in USB devices that do not have a special driver.
The device handles the following ioctl(2) calls:
USB_GET_DEVICEINFO
struct, usb_device_info, *devinfo
Get summarized information about the device.
USB_GET_REPORT_ID
int, *repid
Get the report identifier used by this HID report.
USB_GET_REPORT_DESC
struct, usb_ctl_report_desc, *repdesc
Get the HID report descriptor. Using this descriptor the exact layout and meaning of data to/from the device can be found. The report descriptor is delivered without any processing.
struct usb_ctl_report_desc { int ucrd_size; u_char ucrd_data[1024]; /* filled data size will vary */ };
USB_GET_REPORT
struct, usb_ctl_report, *rep
Get a report from the device without waiting for data on the interrupt pipe. The ucr_report field indicates which report is requested. It should be
UHID_INPUT_REPORT
,UHID_OUTPUT_REPORT
, orUHID_FEATURE_REPORT
.
struct usb_ctl_report { int ucr_report; u_char ucr_data[1024]; /* filled data size will vary */ };
USB_SET_REPORT
struct, usb_ctl_report, *rep
Set a report in the device. The
report
field indicates which report is to be set. It should beUHID_INPUT_REPORT
,UHID_OUTPUT_REPORT
, orUHID_FEATURE_REPORT
.
The generic ioctls
FIONBIO
and
FIOASYNC
are supported by
uhid.
Use read(2) to get data from the device. Data should be read in chunks of the size prescribed by the report descriptor.
Use
write(2)
to send data to the device.
Equivalent to issuing an
ioctl(2)
USB_SET_REPORT
request with the report set to
UHID_OUTPUT_REPORT
.
Data should be written in chunks of the size prescribed by the report
descriptor.
FILES #
/dev/uhid*
ERRORS #
If ioctl(2) fails, errno(2) is set to one of the following:
[EIO
]
The device could not fulfill a
USB_GET_REPORT
orUSB_SET_REPORT
request.
[EINVAL
]
The report specified by the ucr_report field in a
USB_GET_REPORT
orUSB_SET_REPORT
request was invalid.
[ENOTTY
]
Unrecognized command.
If read(2) fails, errno(2) is set to one of the following:
[EIO
]
The device has already been detached.
[EWOULDBLOCK
]
Non-blocking I/O was selected and no data were available.
If write(2) fails, errno(2) is set to one of the following:
[EIO
]
The device has already been detached or the same device does not have a corresponding output report.
[EMSGSIZE
]
The size of the supplied data exceeds the size of the output report.
SEE ALSO #
usbhidctl(1), usbhid(3), intro(4), uhidev(4), usb(4)
HISTORY #
The uhid driver appeared in OpenBSD 2.6.
OpenBSD 7.5 - September 15, 2021