ST(4) - Device Drivers Manual #
ST(4) - Device Drivers Manual
NAME #
st - SCSI tape driver
SYNOPSIS #
st* at scsibus? #st0 at scsibus0 target 4 lun 0 (fixed-configuration example)
DESCRIPTION #
The
st
driver provides support for
SCSI
tape drives.
SCSI
devices have a relatively high level interface and talk to the system via a
SCSI
adapter and a
SCSI
adapter driver
e.g.
ahc(4).
The
SCSI
adapter must be separately configured into the system before a
SCSI
tape can be configured.
As the
SCSI
adapter is probed during boot, the
SCSI
bus is scanned for devices.
Any devices found which answer as
Sequential
type devices will be attached to the
st
driver.
MOUNT SESSIONS #
The st driver is based around the concept of a mount session, which is defined as the period between the time that a tape is mounted and the time when it is unmounted. Any parameters set during a mount session remain in effect for the remainder of the session or until replaced. The tape can be unmounted, bringing the session to a close in several ways. These include:
Closing an “unmount device”.
Using the
MTOFFL
ioctl(2) command, reachable through the offline command of mt(1).
EJECT and REWIND #
Bit 0 of the minor number specifies whether a rewind is attempted when the device is closed. When it is set, the device will not attempt a rewind on close and the device will have an ’n' in its name. For example, /dev/rst0 will rewind on close but /dev/nrst0 will not.
Bit 1 of the minor number specifies whether an eject is attempted when the device is closed. When it is set, the device will attempt to eject its media on close and the device will have an ’e' in its name. For example, /dev/erst0 will eject its media on close but /dev/rst0 will not.
If both bit 0 and bit 1 are set then an eject will be attempted without a rewind and the device will have both an ’e' and an ’n' in its name. For example, /dev/enrst0 will eject its media without first rewinding it on close.
There is no guarantee that the attempted eject or rewind will be supported by the actual hardware.
BLOCKING MODES #
SCSI
tapes may run in either
variable
or
fixed
block-size modes.
Most
QIC
-type
devices run in fixed block-size mode, whereas most nine-track tapes
and many new cartridge formats allow variable block-size.
The difference between the two is as follows:
Variable block-size:
Each write made to the device results in a single logical record
written to the tape.
One can never read or write
part
of a record from tape (though you may request a larger block and
read a smaller record); nor can one read multiple blocks.
Data from a single write is therefore read by a single read.
The block size used may be any value supported by the device, the
SCSI
adapter and the system (usually between 1 byte and 64 Kbytes,
sometimes more).
When reading a variable record/block from the tape, the head is logically considered to be immediately after the last item read, and before the next item after that. If the next item is a file mark, but it was never read, then the next process to read will immediately hit the file mark and receive an end-of-file notification.
Fixed block-size data written by the user is passed to the tape as a succession of fixed size blocks. It may be contiguous in memory, but it is considered to be a series of independent blocks. One may never write an amount of data that is not an exact multiple of the blocksize. One may read and write the same data as a different set of records. In other words, blocks that were written together may be read separately, and vice-versa.
If one requests more blocks than remain in the file, the drive will
encounter the file mark.
Because there is some data to return (unless there were no records before
the file mark), the read will succeed, returning that data.
The next read will return immediately with an
EOF
.
(As above, if the file mark is never read, it remains for the next process
to read if in no-rewind mode.)
FILE MARK HANDLING #
The handling of file marks on write is automatic. If the user has written to the tape, and has not done a read since the last write, then a file mark will be written to the tape when the device is closed. If a rewind is requested after a write, then the driver assumes that the last file on the tape has been written, and ensures that there are two file marks written to the tape. The exception to this is that there seems to be a standard (which we follow, but don’t understand why) that certain types of tape do not actually write two file marks to tape, but when read, report a “phantom” file mark when the last file is read. These devices include the QIC family of devices. (It might be that this set of devices is the same set as that of fixed. This has not yet been determined, and they are treated as separate behaviors by the driver at this time.)
IOCTLS #
The following
ioctl(2)
calls apply to
SCSI
tapes.
Some also apply to other tapes.
They are defined in the header file
<sys/mtio.h>.
MTIOCGET
struct mtget *
Retrieve the status and parameters of the tape.
MTIOCTOP struct mtop *
Perform a multiplexed operation. The argument structure is as follows:
struct mtop { short mt_op; int mt_count; };
The following operation values are defined for mt_op:
MTWEOF
Write mt_count end of file marks at the present head position.
MTFSF
Skip over mt_count file marks. Leave the head on the EOM side of the last skipped file mark.
MTBSF
Skip backwards over mt_count file marks. Leave the head on the BOM (beginning of media) side of the last skipped file mark.
MTFSR
Skip forwards over mt_count records.
MTBSR
Skip backwards over mt_count records.
MTREW
Rewind the device to the beginning of the media.
MTOFFL
Rewind the media (and, if possible, eject). Even if the device cannot eject the media, it will often no longer respond to normal requests.
MTNOP
No-op; set status only.
MTCACHE
Enable controller buffering.
MTNOCACHE
Disable controller buffering.
MTSETBSIZ
Set the blocksize to use for the device/mode. If the device is capable of variable blocksize operation, and the blocksize is set to 0, then the drive will be driven in variable mode. This parameter is in effect for the present mount session only.
MTSETDNSTY
Set the density value (see mt(1)) to use when running in the mode opened (minor bits 2 and 3). This parameter is in effect for the present mount session only.
MTIOCIEOT
Set end-of-tape processing (not presently supported for st devices).
MTIOCEEOT
Set end-of-tape processing (not presently supported for st devices).
FILES #
/dev/[e][n][r]st[0-9]
General form.
/dev/rst0
No eject, rewind on close.
/dev/nrst0
No eject, no rewind on close.
/dev/erst0
Eject, rewind on close.
/dev/enrst0
Eject, no rewind on close.
SEE ALSO #
chio(1), mt(1), intro(4), mtio(4), scsi(4)
HISTORY #
This
st
driver was originally written for
Mach
2.5 by Julian Elischer, and was ported to
NetBSD
by Charles Hannum.
This man page was edited for
NetBSD
by Jon Buller.
OpenBSD 7.5 - March 31, 2022