OPENPROM(4) - Device Drivers Manual

OPENPROM(4) - Device Drivers Manual #

OPENPROM(4) - Device Drivers Manual

NAME #

openprom - OPENPROM interface

SYNOPSIS #

#include <machine/openpromio.h>

DESCRIPTION #

The file /dev/openprom is an interface to the OPENPROM. This interface is highly stylized, ioctls are used for all operations. These ioctls refer to “nodes”, which are simply “magic” integer values describing data areas. Occasionally the number 0 may be used or returned instead, as described below.

The calls that take and/or return a node use a pointer to an int variable for this purpose; others use a pointer to a struct opiocdesc descriptor, which contains a node and two counted strings. The first string is comprised of the fields op_namelen (an int) and op_name (a char *‌), giving the name of a field. The second string is comprised of the fields op_buflen and op_buf, used analogously. These two counted strings work in a “value-result” fashion. At entry to the ioctl, the counts are expected to reflect the buffer size; on return, the counts are updated to reflect the buffer contents.

The following ioctls are supported:

OPIOCGETOPTNODE

Takes nothing, and fills in the options node number.

OPIOCGETNEXT

Takes a node number and returns the number of the following node. The node following the last node is number 0; the node following number 0 is the first node.

OPIOCGETCHILD

Takes a node number and returns the number of the first “child” of that node. This child may have siblings; these can be discovered by using OPIOCGETNEXT.

OPIOCGET

Fills in the value of the named property for the given node. If no such property is associated with that node, the value length is set to -1. If the named property exists but has no value, the value length is set to 0.

OPIOCSET

Writes the given value under the given name. The OPENPROM may refuse this operation, in this case EINVAL is returned.

OPIOCNEXTPROP

Finds the property whose name follows the given name in OPENPROM internal order. The resulting name is returned in the value field. If the named property is the last, the “next” name is the empty string. As with OPIOCGETNEXT, the next name after the empty string is the first name.

FILES #

/dev/openprom

ERRORS #

The following may result in rejection of an operation:

[EINVAL]

The given node number is not zero and does not correspond to any valid node, or is zero where zero is not allowed.

[EBADF]

The requested operation requires permissions not specified at the call to open().

[ENAMETOOLONG]

The given name or value field exceeds the maximum allowed length (8191 bytes).

[ENOMEM]

Memory could not be allocated.

[ENOTTY]

The ioctl is not supported on this architecture.

SEE ALSO #

ioctl(2), eeprom(8)

HISTORY #

The openprom interface first appeared in OpenBSD 3.0 for sparc64. It has been available on macppc since OpenBSD 4.3, on octeon since OpenBSD 6.0, on armv7 since OpenBSD 6.0, and on arm64 since OpenBSD 6.1.

BUGS #

Due to limitations within the OPENPROM itself, these functions run at elevated priority and may adversely affect system performance.

OpenBSD 7.5 - September 11, 2022