APM(4) - Device Drivers Manual (loongson) #
APM(4) - Device Drivers Manual (loongson)
NAME #
apm - advanced power management device interface
SYNOPSIS #
apm0 at mainbus0
DESCRIPTION #
The apm driver provides generic power and battery control, relying on device specific drivers to provide the actual information.
The
apm
driver provides an interface which simulates the Advanced Power Management
(APM
)
BIOS functions encountered on some x86 hardware.
The BIOS functions are translated into the appropriate microcontroller requests
by the hardware specific drivers, like
ykbec(4).
Currently only battery level, AC connection, and charging status are available
from the
apm
device.
Suspend/resume and other power events are not yet supported.
The apm driver implements the following ioctl(2) calls. They are defined in <machine/apmvar.h>.
APM_IOC_GETPOWER
(
struct apm_power_info
) Request the current power state. The argument structure is as follows:
struct apm_power_info { u_char battery_state; u_char ac_state; u_char battery_life; u_char spare1; u_int minutes_left; u_int spare2[6]; };
The following values are defined for battery_state:
APM_BATT_HIGH
Battery has a high state of charge.
APM_BATT_LOW
Battery has a low state of charge.
APM_BATT_CRITICAL
Battery has a critical state of charge.
APM_BATT_CHARGING
Battery is not high, low, or critical and is currently charging.
APM_BATT_UNKNOWN
Cannot read the current battery state.
APM_BATTERY_ABSENT
No battery installed.
The following values are defined for ac_state:
APM_AC_OFF
External power not detected.
APM_AC_ON
External power detected.
The battery_life value contains the estimated percentage of battery life available. 100% indicates a full charge.
The minutes_left value contains the estimated number of minutes of battery life remaining.
APM_IOC_PRN_CTL
(
int
) This ioctl(2) controls message output by the apm driver when a power change event is detected. The integer parameter is one of:
APM_PRINT_ON
All power change events result in a message. This is the normal operating mode for the driver.
APM_PRINT_OFF
Power change event messages are suppressed.
APM_PRINT_PCT
Power change event messages are suppressed unless the estimated battery life percentage changes.
FILES #
/dev/apm
APM data device. May only be opened read-only. May be opened by multiple concurrent users.
/dev/apmctl
APM control device. May be opened read-write or write-only. May only be opened by one user at a time. An attempt to open the file when in use will fail, returning
EBUSY
.
SEE ALSO #
intro(4), ykbec(4), apm(8), apmd(8)
BUGS #
Suspend and resume are not supported.
OpenBSD 7.5 - January 30, 2023