ENDRUN(4) - Device Drivers Manual

ENDRUN(4) - Device Drivers Manual #

ENDRUN(4) - Device Drivers Manual

NAME #

endrun - EndRun Technologies native time-of-day message timedelta sensor

SYNOPSIS #

pseudo-device endrun [count]

DESCRIPTION #

This line discipline interfaces serial EndRun Technologies devices.

The line discipline is enabled by the following sequence:

#include <sys/ioctl.h>
int ldisc = ENDRUNDISC, fildes; ...
ioctl(fildes, TIOCSETD, &ldisc);

The byte stream is unaltered by the line discipline which maintains a timedelta sensor using the EndRun data. The timedelta sensor will appear as endrun* in the list of sensors and the delta (in nanoseconds) between the received time information and the local time can be accessed through the sysctl(8) interface.

SENSOR STATES #

The quality of the timedelta is reported as the sensor status:

OK

The time information is valid. The timedelta is safe to use for applications like ntpd(8).

WARN

The attached receiver has been indicating a warning condition for at least the last ten minutes. The timedelta should be used with care.

CRITICAL

tty timestamping has been turned on but there is no PPS signal present or the receiver indicated a warning condition for at least the last twenty minutes. Check your hardware.

The status of a second sensor is used to report the status of the device itself using the Time Figure Of Merit (TFOM) character:

OK

The clock is synchronized. TFOM is 6-8.

WARN

The clock is synchronized and the time error is greater than 10ms or the clock is in the unsynchronized state. TFOM is 9.

CRITICAL

The TFOM is invalid.

SEE ALSO #

tty(4), ldattach(8), ntpd(8), sysctl(8)

HISTORY #

The endrun interface first appeared in OpenBSD 4.6.

OpenBSD 7.5 - January 15, 2015